Search This Blog

October 26, 2008

VSTS 2008 web test recorder bar does not show up

During this month, I have used VSTS 2008 web test to create more than 200 automated tests in my current Microsoft Project without any problem. The test automation runs very smoothly every day.

Today I used my personal PC in my house to create one simple automated test. Unluckily, the recorder bar didn’t show up. My PC environment is as follows:

Windows XP SP3, IE 7, VSTS 2008 SP1.

I finally found that my Microsoft Web Test Recorder was disabled. Only what I needed to do was launch IE 7, go to Internet Options/Programs/Manage Add-ons and enable Microsoft Web Test Recorder.

After that, the issue was fixed. I could create the simple web test successfully.

8 comments:

Erik Cox said...

Strange..I have the same PC environment:
Windows XP SP3, IE 7, VSTS 2008 SP1.
and my Microsoft Web Test Recorder was enabled from the start - I never had the need to do anything special..to enable it..

Ray said...

Erik,
I don't have to enable anything in my company PC . In my personal PC, I need to enable it. I don't know why.
But I helped my coworker's PC enable this one. It worked.

Anonymous said...

Strange, I have enabled the Web Test Recorder, but the VSTS does not recording my tests.

Environment: Windows 7, IE 8, VSTS 2008 SP1

Ray said...

Your environment is different from mine. You use Windows 7 and IE8(RC1 or RC).

I believe some components are disabled even if you enabled the Web Test Recorder.

aranda0408 said...

Environment: XP sp3, IE8, VSTS 2008, Web Test Recorder addon enabled

The addon is enabled but I'm still having trouble seeing the recorder bar consistently. I've tried on different days and sometimes it works and sometimes it doesn't. I even changed the starting URL as per (http://blogs.msdn.com/mtaute/archive/2007/11/09/diagnosing-and-fixing-web-test-recorder-bar-issues.aspx). Any thoughts?

Ray said...

Did you install VSTS 2008 SP1?

aranda0408 said...

This may be a dumb question, but does the Visual Studio SP1 do the trick or is there a SP1 specifically for VSTS version?

Ray said...

Can you check your VSTS 2008 version? If you don't install SP1, just install it. SP1 covers so many bug fixes.